Не устанавливается ЛОЛ на Линуксе

Тема в разделе "Вопросы и ответы", создана пользователем Konark, 6 мар 2016.

  1. Konark

    Konark Опытный Пользователь

    Хочу установить лол на линукс с помощью программы Playonlinux, лаунчер устанавливается, но как только дело доходит до обновления, то возникают проблемы. Все файлы скачиваются, и потом как начинается установка, то она длится около 1% в пол часа. Если закрываю лаунчер, то скидывается до 33 процентов и заново начинает качать.
    Кто сталкивался с подобным? И кто вообще играет на линуксе?
     
  2. Koringvias

    Koringvias The Trickster Лидер Сообщества

    А нет варианта скачать клиент с торрента?
     
  3. Konark

    Konark Опытный Пользователь

    Ну, это же эмулятор виндовса и нужен именно экзешник. Или он сам скачивает лаунчер с официального сайта.
     
  4. Koringvias

    Koringvias The Trickster Лидер Сообщества

    Тогда, боюсь, не знаю что подсказать - никогда не приходилось иметь дел с Линуксом.
    Даже не знаю, есть ли смысл писать в саппорт - уж больно специфичная проблема.
     
  5. Konark

    Konark Опытный Пользователь

    Скорее в саппорт Playonlinux, так как по сути клиент этот виндовса. У риотов нету клиента для линукса. Только винда и мак. Может скоро и линукс будет, но тогда мне не нужно будет уже :)
    У меня есть ноут с виндовсом. Просто хотел сюда поставить, чтобы вдвоем играть.
     
  6. Kombala

    Kombala «Модуль Чата» Отдел модераторов

    Попробуй через Вайн запустить. Playonlinux я особо никогда не доверял и в подобных случаях пользовался вайном.
     
  7. Koringvias

    Koringvias The Trickster Лидер Сообщества

    Если найдешь решение - поделись.
     
  8. Kombala

    Kombala «Модуль Чата» Отдел модераторов

    https://appdb.winehq.org/objectManager.php?sClass=version&iId=31794

    Голд статус в вайне - должно без особых шаманств работать.
    --- добавлено: 6 мар 2016 ---
    Насчет патчера:
    The patcher provided by Riot Games work absolutely fine and with no known bugs affecting the patcher itself. However there is an alternative available.

    It is JAVA based but requires some advanced knowledge on how to build .JARs from JAVA class sources.


    https://github.com/xupwup/LoLPatcher
     
    Konark и Koringvias нравится это.
  9. Konark

    Konark Опытный Пользователь

    Разве плэйонлинукс не использует вайн? Я в настройках выбираю какую версию вайна использовать.

    Если бы я ещё был продвинутым в линуксе...
     
  10. Kombala

    Kombala «Модуль Чата» Отдел модераторов

    Использует, да, не знаю как сейчас, но когда я встречался с Playonlinux это был 10й год и PoL была весьма и весьма корявая, к тому же, Wine можно вручную патчить, гибко настроивать, а PoL (по крайней мере 6 лет назад) в этом плане был довольно "деревянным".
    Если я правильно понял - по ссылке человек написал альтернативный патчер на яве, просто скачивай с гитхаба пакет и устанавливай, ну либо собирай. Для этого "продвинутым в линуксе" и не нужно быть.
    --- добавлено: 6 мар 2016 ---
    http://lolpatcher.xupwup.nl/ Вот более точная ссылка на патчер.
    [​IMG]
    --- добавлено: 6 мар 2016 ---
    Скачиваешь зип, и все по инструкции:

    How to build:
    - Build the Maestro project with netbeans and copy the jar from Maestro/dist/ to this project
    - build this project
    - get jarsplice
    - select all jars in dist/ and dist/lib/
    - select all natives in lwjgllib/
    - Main class = lolpatcher.Main
    - Build jar or exe

    Run jar with
    $ java -jar filename.jar

    alternative:

    - Build the Maestro project with netbeans and copy the jar from Maestro/dist/ to this project
    - build this project
    - then run:

    $ java -Djava.library.path=lwjgllib -jar dist/LoLPatcher.jar
     
    Konark нравится это.
  11. Grand_Espada

    Grand_Espada Worst Marksman

    всегда думал что линукс только через консоль нормально работает)
     
  12. Konark

    Konark Опытный Пользователь

    Без всяких вайнов и тд.? Просто по инструкции?
     
  13. Kombala

    Kombala «Модуль Чата» Отдел модераторов

    Да я то откуда знаю, я уже 6 лет линуксом не пользуюсь, я вам ссылку дал - пройдите да попытайтесь. Но вообще, да, у вас в чем проблема? Патчер ритов не работает, не устанавливает вам лолец. Вот держите АЛЬТЕРНАТИВНЫЙ патчер, который написан на яве, и поэтому будет работать на линуксе НАТИВНО, без PoL / Wine.

    P.S. Не понимаю, зачем устанавливать на свой PC линукс, если не умеете с ним работать? :braum:
    --- добавлено: 6 мар 2016 ---
    Да, просто по инструкции. Скачиваете zip архив с сайта, скачиваете java IDE (netbeans) и далее по пунктам, создаете проект, выделяете то, сё и собираете. После чего собранный патчер включаете и наслаждаетесь долгожданной загрузкой и установкой лольца.
     
  14. hodok

    hodok Новичок